Alex's-Blog (Alexander Palm aus Hannover)

…hier bloggt Alexander Palm aus Hannover

Alexander Palm - Web-Junkie, geek, iPhone-, AVM-, FRITZ!Box-, Sipgate-, jQuery-Fan.

 

Alex's-Blog (Alexander Palm aus Hannover) - …hier bloggt Alexander Palm aus Hannover

Apple Kontakte.app eigener Eintrag (vCard) weg

Vorgeschichte

Ein Blick in die Anrufliste meines Handys (iPhone) ließ mich erschrecken – ein Anruf von einer Nummer, die nicht im Handy gespeichert ist, mir aber sehr bekannt vorkommt. Klar es war meine Festnetznummer.

Also das Adressbuch aufgerufen und wieder erschrocken: mein Eintrag war weg! Dann ein Blick in die Kontakte.app auf dem Mac, ein erneuter Schock: Der Kontakt, der mit dem Benutzerkonto verknüpft ist – also meine vCard: weg!

Die Probleme…

…gut dachte ich – kein Thema, Du hast ja TimeMachine – und siehe da – mein Kontakt war auch zu sehen. Kurz angeklickt und auf Wiederherstellen gedrückt. “Zurück in der Gegenwart” ein erneuter Schreck: der Kontakt ist wieder weg.

Der Versuch einen neuen Kontakt anzulegen gelang auf Anhieb – das ist also kein Problem – aber will ich jetzt alle meine 40 Daten aus der vCard der TimeMachine abschreiben? Nein!

Also den neuen Kontakt wieder löschen – Fehler – der Mac bestätigte meinen Löschversuch mit einem “Plong”-Sound der immer kommt, wenn man etwas falsch macht. Hmmm – und jetzt?

Eine vCard ex- oder importieren gelang auch nicht – weder lokal noch in der TimeMachine. Was jetzt?

Die Lösung

  • TimeMachine starten und den Stand suchen in dem mein Kontakt noch vorhanden ist.
  • Kontakt öffnen und auf den “Teile”-Button Teilen drücken.
  • Dort “per Mail senden” auswählen.
  • TimeMachine verlassen (mit Abbruch) und das Fenster mit der neuen e-Mail suchen.
  • Aus der e-Mail die vCard heraus ziehen z.B. auf den Desktop.
  • Da ein Import lokal ja nicht funktioniert jetzt bei iCloud anmelden und dort zu den Kontakten wechseln.
  • Import auswählen und die vCard hochladen.
  • etwas warten und sich freuen, dass der Eintrag wieder in der Kontakte.app auftaucht.

Nach der Aktion kann man auf einmal wieder Kontakte löschen, importieren und exportieren. Irgendwas an dem Kontakt, der mit dem Nutzerkonto verknüpft ist, muss die App total aus dem Tritt gebracht habe.

Evtl. kann ich ja jemandem hiermit helfen, dem es so geht wie mir – dass ich zwischendurch erfolglos mit der Hotline telefoniert habe, will ich hier gar nicht mehr beschreiben – aber kurz gesagt – da wurde mir noch nie geholfen. :-o

iOS6 mehrere Mail-Adressen pro Account – leider jetzt sortiert

iOS6 ist wirklich gut, auch wenn ich die Facebook-Anbindung nicht so wirklich gelungen finde. Unabhängig von den gemeldeten Problemen die zu ungewollten MMS führen können, finde ich es auch sehr mühsam, dass die manuellen Verknüpfungen der Profile mit Kontakten offensichtlich nicht gesynced werden. So muss man sie auf jedem Gerät erneut verknüpfen.

Aber darum soll es hier gar nicht gehen. Was ich gerade mit erschrecken festgestellt habe:
Hat man zu einem Mail-Account mehr als eine Adresse mit Komma getrennt hinterlegt (weil man den Account ja nur einmal abrufen will, aber mit unterschiedlichen Adressen davon schreiben möchte), so wurden die Adressen bis iOS5 immer in der Reihenfolge in der Mail-App angezeigt und genutzt, wie man sie eingetragen hatte …

Mit iOS6 ist das anders – nun werden sie mal eben Alphabetisch sortiert. Ok, ist ja erstmal nicht weiter schlimm … wenn Mail nicht beim Antworten immer die erste der Adressen eines Accounts nutzen würde … so kann es passieren, dass man auf einmal mit einer total anderen Adresse antwortet als man die Unterhaltung angefangen hat.

Ok, könnte man auch noch sagen, na und? Aber was ist wenn ich z.B. eine Adresse habe und eigentlich davon ausging mit zu schreiben … da wird es dann schon peinlich, wenn man nicht auf seinen Absender achtet.

Bisher konnte man den Default durch die Reihenfolge selbst bestimmen, jetzt ist es halt einfach sortiert … schön ist das nicht …

Apples Java for OS X 2012-005

Grundsätzlich ist es ja nett, dass ein Update kommt, nach der ganzen Aufregung um Java die letzten Wochen… Also installiere ich mir die Version von Apple auch brav aus dem AppStore. Aber was muss ich sehen, als ich auf der Console ein “java -version” schreibe?

java version “1.7.0_06″
Java(TM) SE Runtime Environment (build 1.7.0_06-b24)
Java HotSpot(TM) 64-Bit Server VM (build 23.2-b09, mixed mode)

Sollte da nicht was von Java 1.6 Update 35 stehen? Zumindest ist davon in der Updateinfo die Rede.

Was habe ich also gemacht? Das Paket nochmal runter geladen und gesucht, wo sich dieses Java versteckt. Da bin ich auf ein Paket in dem Update gestoßen:

“JavaEssentials.pkg”

Dieses beinhaltet eine Verzeichnis Struktur, in der ich auch das Java gefunden habe, das in der Console die 1.7.0_06 ausgibt:

/System/Library/Frameworks/JavaVM.framework/Versions/A

Also ausgepackt und gestartet – siehe da – das ist die Version 1.7.0_06.

Also auf die Suche gegangen wieso das da verlinkt ist…. dabei wurde ich in der systemeigenen Java-Konfig fündig… Unter Programme/Dienstprogramme/Java-Einstellungen:

Java Einstellungen Mac OS X

Bei mir war da das Java 7 noch ganz oben – als ich auf “Standard wiederherstellen” gedrückt habe, sah es dann so aus wie auf dem Foto – und ein erneuter Check auf der Console ergab die erwünschte Ausgabe:

java version “1.6.0_35″
Java(TM) SE Runtime Environment (build 1.6.0_35-b10-428-11M3811)
Java HotSpot(TM) 64-Bit Server VM (build 20.10-b01-428, mixed mode)

Ist zwar nicht das neuste Java – aber laut Apple ja ein sicheres… ;-) Hoffen wir das mal.

Apple, da werden Sie geholfen?

Nach der Mail von heute morgen, zu meinem Anruf gestern bei Apple bezüglich des Problems mit der Zeit auf dem iPhone. Musste ich mir doch mal etwas Luft machen…
Wie gesagt – die Hardware finde ich gut. :-)

So steht es jetzt auch in der Antwort zu dem Fragebogen – auch wenn das mit Sicherheit nichts nutzt:

Der nette Herr am Telefon kann da ja nichts dafür, dass ihr so eine komische Firmenpolitik verfolgt.

Das Problem mit der Zeit, auf dem iPhone nach dem Update, haben laut Internet-Foren (auch eurem Eigenen) hunderte von Usern weltweit.

Klar verstehe ich, dass man für ein Problem zahlen muss das man nur alleine (verschuldet) hat, weil man zu blöde ist das Telefon zu bedienen – aber bei einem Massenproblem (ich habe drauf hingewiesen das es im Internet zuhauf davon zu lesen gibt) solle sich nach einem großen Update (iOS 4.2.1) doch wohl jeder Hersteller mal interessieren?!

Ich habe bei den letzten Calls schon viel geschluckt, weil ich seit einem Jahr eigentlich überzeugter Apple-Jünger war – aber erstmal die teure Hotline (gut das habt ihr jetzt geändert), da dann die lange Wartezeit und für die Beratung noch mal Geld in die Hand nehmen. Bis jetzt hat auch noch KEIN Anruf bei Euch meine gemeldeten Probleme gelöst, alles habe ich nach einem Anruf dann selber via Internet-Suche doch irgend-wann/-wo gefunden.

Aber Ihr werdet schon wissen wozu das gut sein soll.

Spaß mit Apple und Garantie

Ich habe ein Zusatznetzteil für mein iPad. Dieses ist jetzt kaputt – gut dass es nur das “Zweitnetzteil” ist.
Aber, es ist echt schwer Ersatz zu bekommen – bin ja schon kurz davor, einfach ein Neues zu kaufen!

Sa. rief ich beim Apple-Support an, weil ich dachte, dass ich dort richtig bin. Nachdem ich x Mal erklärt habe, dass es sich um ein Zusatzartikel handelt, wurde ich dann an Apple-Verkauf verwiesen. Die haben aber Sa. nicht auf und daher soll ich Montag mal anrufen.

Soweit so gut. Das Telefonat war schon Mal 30 Minuten für nichts.

Heute rufe ich also beim Verkauf an. Die erste Dame war total nett und meinte sie sendet mir eine Mail mit einer Retoure-Nummer, mit der ich dann mein Defektes zurück schicken soll und ein Neues bekomme. Spitze, dachte ich.

Leider kam keine Mail (bis jetzt noch nicht: 2h). Ich also noch Mal angerufen und gefragt ob das alles gut ging oder die meine Adresse vielleicht falsch verstanden haben. Da wurde mir erklärt, dass ich ja beim Support anrufen solle. Nach langem hin und her (also Erklärung, dass der Support meinte ich sollte hier anrufen und dass die Dame vor hier kein Problem damit hatte) wollte sie sich dann erkundigen, was mit meiner Anfrage passiert ist. Gut also wieder Musik…. nach der Musik kam ein “Danke das sie gewartet haben…. *klick* *düdüdüdüd* – hmmm und jetzt?

Also noch ein Anruf – nach langem Klingeln hatte ich den Support dran – wusste ich aber nicht – wurde wohl durch gestellt weil beim Verkauf nur bis 18h jemand da ist. Nachdem wir geklärt hatten, dass ich Ihn gar nicht angerufen habe und er mir ja gar nicht helfen kann, wurde ich jetzt auf morgen verwiesen.
Da bin ich aber gespannt wie das jetzt weiter geht…. :-D

Update 24.08.2010

Da war ich wohl mal wieder zu ungeduldig. ;-)
Heute morgen kamen jetzt Mails für die Versandvorbereitung eines neuen Netzteils und mit Infos für die Rücksendung. Geht ja doch besser als ich gestern noch angenommen hatte. – Danke!

Update 27.08.2010

Leider hat mir Apple das Falsche geschickt. Naja was soll’s, habe ich noch ein Ersatznetzteil für das iPhone 4, leider kann man mit dem Ding kein iPad laden, da es zu wenig Watt hat. Hatte ja auch extra gesagt das es um das 10 Watt Netzteil für das iPad ginge UND die Bestellnummer x Mal mitgeteilt.

Kurz um habe ich es jetzt selber bestellt und schicke das kaputte einfach zurück – mal sehen ob ich trotzdem mein Geld zurück bekomme, habe ja eine Retourennummer.

Doch keine Lösung (Mac OS X 10.6.2)

Wie neulich schon berichtet, habe ich kürzlich mit der Support-Hotline von Apple telefoniert. Heute habe ich dort wieder angerufen, da die beiden Tipps wohl doch nicht die Lösung des Problems waren. Inzwischen bin ich etwas schlauer und habe einen “Workaround”. Wenn man sich beim Auftreten des Fehlers (Trackpad funktioniert nicht in vollem Umfang und es gibt eine Flut von Fehlermeldungen des hidd-Prozesses im syslog) einmal mit dem User abmeldet und wieder anmeldet, dann läuft alles ganz normal. Außerdem tritt das Problem nur direkt nach dem Hochfahren bzw. der ersten Anmeldung auf. Diese neuen Erkenntnisse habe ich (nach 20 Minuten in der Warteschlange, bei schrecklicher Radio-Musik die kaum zu verstehen war, und 2,80 Euro später) dem Support mitgeteilt. Neues Vorgehen nach meiner Beschreibung war:

  • von Installations-CD booten
  • Rechte des Filesystems prüfen und reparieren
  • Filesystemcheck laufen lassen und trotz OK Meldung auch reparieren lassen

Ich habe das alles mit mir machen lassen. Aber als es dann hieß, dass wir einen HW Call aufmachen sollten, wenn der Fehler noch einmal auftritt, habe ich noch einmal darauf hingewiesen, dass der Fehler nur nach dem ersten Login auftritt und auch nicht immer. Darauf wurde ich nach knapp (insgesamt jetzt schon) einer Stunde an den 2. Level durchgestellt.

Dort erklärte man mir dann, dass der hidd – Dienst (hid = Human Interface Device) nun aber auch so gar nichts mit dem Trackpad zu tun habe – schließlich würde es diesen Fehler ja auch auf dem iMac geben und der hat ja kein TrackPad. Muss ich dazu noch etwas sagen? Nachdem ich aber nicht locker ließ, bekam ich eine eMail-Adresse, bei der ich mich dann melden soll, wenn der Fehler noch einmal auftritt. Die genaue Fehlermeldung wollte aber immer noch keiner wissen.

“Die interessiert mich erst wenn der Fehler wieder auftritt”

OK – also ich soll jetzt, wenn der Fehler wieder auftritt, über den System-Profiler die dort ermittelten Daten an Apple senden und danach eine Mail an diese Adresse mit dem Hinweis auf die gesendeten Daten und den Call. Ich hoffe mal, dass in dem System-Profiler auch Einträge aus dem syslog sind, ich habe jedenfalls keine gesehen.

Vielleicht habe ich ja auch Glück und in einem Forum oder auf mein Blog meldet sich jemand zu dem Problem. Auf jeden Fall ist diese Art von Support (aus meiner Sicht am Problem vorbei) kein Grund für mich, eine “AppleCare Protection Plan” zu kaufen.

So nun bin ich über 8 Euro ärmer (davon fast 3 Euro Wartemusik) und habe noch immer keine Lösung.

Mac OS X Update auf 10.6.2 brachte Probleme mit sich…

Nachdem ich auf meinem MacBookPro das Update durchgeführt hatte, ging auf einmal bei dem Trackpad nichts mehr, wofür man mehr als 2 Finger nutzen müsste. Außerdem war das system.log geflutet (ca. 500 pro Sekunde) von Meldungen der Art:

/usr/libexec/hidd[39]: IOHIDEventQueueEnqueue: Error enqueuing memory. (0xe00002e8)

Nach erfolgloser Suche im Netz habe ich dann zum ersten Mal die Apple-Hotline angerufen. 15 Minuten nach der Warteschleife, mit super Musik die offensichtlich vom Radio eingespielt wurde und viel zu leise war, hatte ich dann eine wirklich nette und super kompetente Dame am Telefon. An dieser Stelle noch ein herzliches Dankeschön!

Sie gab mir zwei Tipps, die ich nicht für mich behalten will – ganz einfach daher, weil sie geholfen haben :-)

Und siehe da – alles ist wieder gut. Trackpad macht was es soll und die system.log gibt auch wieder Ruhe.

Faxdrucker für Sipgate auf dem Mac

Einige Erfahrungen habe ich nun auf dem Mac schon gemacht. Schade ist, dass viele Dienste Macs (noch) nicht mit allem unterstützen. So gibt es z.B. bei Sipgate einen FAX-Drucker-Treiber, um direkt vom PC zu faxen. Für den Mac bietet Sipgate da (noch) keine Lösung an. Bei meiner Suche bin ich auf Fossi gestoßen, eine wirklich super und einfach zu bedienende Lösung. Man kann hier über den Standard-Druckdialog (welchen ich bis jetzt in jedem Mac-Programm außer bei OpenOffice so vorgefunden habe) unter dem Dropdown PDF “Fossi” auswählen und los geht’s.

Druckdialog mit Fossi

Nun wird man noch nach einer Nummer gefragt bzw. kann diese durch einen Namen auch aus dem Adressbuch auswählen (sollten Fax-Nummern enthalten sein).

Der Rest geht automatisch und wie gewohnt bei Sipgate. Neben Sipgate unterstützt Fossi auch noch die FAX-Services von:

Unterstützte Online-Fax-DiensteViel Spaß beim Faxen! :-)

Der Neue….

Lange Zeit habe ich mich gegen einen Mac gesträubt. Andreas hat mich immer wieder versucht zu “bekehren”, aber ich wollte mich einfach nicht darauf einlassen. Mir war (und zum Teil ist es auch noch so) ein Mac immer zu sehr bevormundet. Aber nun – vorletzten Samstag – habe ich mich entschlossen, mir einen Mac zu zulegen.

Zu meiner “Schande” muss ich gestehen, dass ich von dem Mac OS X hin und weg bin, es ist super klasse und intuitiv zu bedienen. Ebenso ist die Verarbeitung von einem MacBookPro der aktuellen Baureihe (mit Unibody) echt beeindruckend.

Lange Rede kurzer Sinn – ich bin begeistert! Nur die Bevormundung an einigen Stellen ist einfach eine Frechheit. Man muss falsche Daten eingeben beim erstellen eines GMX-Accounts in Mail.app, damit er nicht automatisch ein POP3-Account anlegt. Eine Änderung auf IMAP ist nachträglich nicht möglich – man muss also versuchen, dass man es schafft die Daten manuell einzugeben. Ebenso iTunes – viele lieben es, ich kann mich noch nicht so richtig damit anfreunden – aber vielleicht kommt das ja noch…. :-)

Und einen Absturz habe ich auch schon geschafft. :-) Wenn man Perian installiert hat, damit das System auch andere Formate abspielen kann als nur das, was Quicktime so kennt, und dann einen Flash-Film läd und gleich in den Ordner wechselt in dem der Film abgespeichert wird – knallt es. Bei mir hat da QTKitServer einen Crash erzeugt und es sogar hin bekommen, dass der Bildschirm schwarz wurde. Alle Programme schienen noch zu laufen, man konnte noch Eingaben machen, sah aber nicht was man tat. Achso der Mauszeiger war noch da. :-) Naja. Irgendwie muss man das System dann um Reboot bewegen… Als dummer Anfänger wusste ich mir nicht anders zu helfen, als mit dem Powerknopf. Aber beim nächsten Mal weiß ich Bescheid: Control-Command-Eject drücken und schwupps NEUSTART ohne Rückfrage!

Wer mag mal testen ob der Fehler mit dem Flash reproduzierbar ist? Bei mir ist er das… aber liegt es an mir oder an der Software? :-)
Wer das mal testen mag:

  • Firefox ein Film bei youtube.de mit z.B. dem DownloadHelper-Plugin für FF laden.
  • In dem Download-Fenster (Aufrufbar über CMD-J) auf “Im Finder anzeigen” klicken während der Download noch läuft!

Ich denke mal das diese QTKit nicht damit klar kommt, schon ein Vorschaubild für einen unvollständigen Film zu erstellen. Schade nur, dass es gleich den ganzen Desktop mit sich zieht. Untersuchen kann ich das ja nicht mehr – weil ich nichts sehe und mit nur dem Crash-Bericht vom QTKitServer kann ich nichts anfangen. Die Zusammenhänge sind also alle nur Vermutungen. Aber evtl. weiß ja jemand was und kann mir noch einen Tipp geben was es sein könnte oder ob ich sogar richtig liege.

Im Gesamtpaket würde ich aber sagen, dass der Kauf eine gute Wahl war!